Skip to main content

Sage Timeslips Obsolescence Policy - Effective August 1st, 2017

Effective August 1st, 2017, Sage Timeslips will support the current version and the year prior. To ensure compliance with operating environments and receive customer support you will be required to upgrade to the current release. Sage only supports an obsolete product while the customer’s support plan is current. Customers using Sage Timeslips 2015 and use the eCenter will have access to use until July 31st, 2017.

To ensure your product is current or to receive more information regarding this obsolescence policy contact JCS at 800.475.1047 or email solutions@jcscomputer.com.

 

Sage offers Support for these versions effective August 1st, 2017:

  • Sage Timeslips 2016
  • Sage Timeslips 2017
  • Sage Timeslips Premium

 

For more information on Sage Timeslips give one of our professional consultants a call 800.475.1047 www.jcscomputer.com

With over 25 years of accounting and business knowledge as well as proficient technical background you get the training and support your business needs and deserves working with a proficient expert consultant. You can work with the same consultant to help you master your Sage Software and for those occasional questions you need help with so you can understand best practices and how to manage your company information and books.

Put our 25 years of experience to work for you!